Low Performance

Incident Report for PRDCNG

Resolved

This issue resolved by itself.
Posted Feb 20, 2023 - 22:56 UTC

Investigating

There is a huge delay when you access to the website. We are currently investigating this issue.
Posted Feb 20, 2023 - 22:48 UTC
This incident affected: Website.